Replies: 9 (Who?), Viewed: 482 times.
Test Subject
Original Poster
#1 Old 3rd Apr 2020 at 6:39 AM
Default Mesh Toolkit messing up skeleton?
Hi, I'm working on an outfit mesh and I had everything in place so I exported WSOs so I could use Cymar's Mesh Toolkit to assign bones. Rather than an issue with auskel, my skeleton is showing up bizarrely when I import the WSO with the new bones. I've tried re-exporting things, but I'm still not sure if this is an issue with milkshape or the mesh toolkit. My assignments look correct at first glance, the skeleton just doesn't.
Screenshots
Advertisement
Mad Poster
#2 Old 3rd Apr 2020 at 1:29 PM
The bone assignments seem fine, so you could try to export as Unimesh, open up an extracted TS2 body mesh for the right age/gender, and import it back over this ("no" to extra skeleton!). Should do the trick. Remember to delete the extra mesh.
Test Subject
Original Poster
#3 Old 3rd Apr 2020 at 9:03 PM
I tried to export as unimesh but the exporter plugin gave me an error message saying "no quaternation values stored". Also when I hit the Anim button and the joint select I can sort of move the joints around and the verts on the mesh are definitely moving along with the joints but it seems that it won't let me export the skeleton like that.
Mad Poster
#4 Old 3rd Apr 2020 at 10:40 PM
Could you upload the Milkshape file?

It does look like it has wrongly imported the skeleton, so there's a chance something went wrong in the conversion process. Have you gone over the steps and made sure you did everything right?
Test Subject
Original Poster
#5 Old 4th Apr 2020 at 2:51 AM Last edited by persongirl : 4th Apr 2020 at 3:30 AM.
I actually got it to work, I just imported the WSO back over the reference mesh instead and then exported to unimesh. I've moved onto SimPE steps now but the entire body is invisible. It's showing up in bodyshop with just a head. I checked my comments but my opacity seems correct, I'm going to keep looking, Maybe I did my alpha wrong? I've read snippets that it's possible to use a texture over 512x512 and the texture i used is 1024 so it could be that and UVs not scaling as well I suppose, I will take a look at both of those things.

EDIT: I tried to preview my mesh and SimPE is giving me an error saying it couldn't find a CRES for my file and can't establish joint hierarchy, i'm guessing because of what happened with the skeleton, is there a way to fix this? The bone definitions are still correctly assigned and when I try using ANIM the verts move along with the joints properly. Is there another way to add a CRES without having to do the bone assignments from scratch?
Mad Poster
#6 Old 4th Apr 2020 at 1:50 PM Last edited by simmer22 : 4th Apr 2020 at 2:01 PM.
The UVs don't care about texture size as long as the image is the same format. For clothes (child and up) they need to be 1024x1024 (toddlers need to be 512x512), so if you're converting from TS4 they probably need to be remapped, as TS4 meshes often use formats like 2048x1024.

In Bodyshop both the alpha and the texture need to be the same size and format, which for clothes is 1024x1024 (512x512 for toddlers), or they won't overlay the skin properly (this is for any clothing parts set as SimSkin in the TXMT, as extra parts set as SimStandardMaterial can deviate somewhat from this). They also have to be UVmapped properly, as Bodyshop does not recognize anything mapped outside the "allowed square" (basically where the texture shows up in the UVmap in Milkshape).

The CRES issue is usually due to an incorrectly made mesh - either the one exported from Milkshape or the actual mesh file. Sometimes the only way to get around this issue is to remake the mesh file from scratch (the SimPE parts). But make sure the mesh does show up fine in Milkshape first, with the proper skeleton and properly assigned. If you get errors either importing or exporting a mesh into Milkshape, it probably has some issues.

If everything seems to be fine with the mesh except the skeleton, try to start with an empty Milkshape, import a mesh with the same age/gender (afbodynaked or some such), then import yours over it (click NO to another skeleton), and delete the first mesh. This should give your mesh a proper skeleton. Make sure the comments are fine, too.

If you still get the CRES issue after importing this mesh, try remaking the mesh from scratch, and make sure you don't click any resources or change anything in the file until you've done "fix integrity" and saved. Messing about with an extracted mesh before doing "fix integrity" and saving is often what causes the problems with a borked CRES in a mesh file. Remember to relink it to the 3DIR.
Test Subject
Original Poster
#7 Old 5th Apr 2020 at 1:22 AM
Okay I got it to appear in SimPE with bones, and i redid my bodyshop clone and that seemed to fix the CRES issues, I found an old thread on leefish.nl where someone having the same issue was suggested to do that. All that's showing up in bodyshop now though is the mesh i cloned from and its textures. I've tried going back through the steps over again, I've assigned the 3DIR correctly to the mesh I made which has both the CRES and shape files, and I got my texture to replace the original one. I'm still worried that I borked something in milkshape even though i'm able to move the mesh with the joints, but I'll keep going through the export and SimPE steps and try again to see if I did something wrong just by not paying attention.
Download - please read all instructions before downloading any files!
File Type: zip inquisitorWIP.zip (268.6 KB, 4 downloads)
Mad Poster
#8 Old 5th Apr 2020 at 2:44 AM
You're going to need the "body" group for the skin parts, and you'll have to make another group (mesh + PropertySet fixes) for the converted mesh. It won't look good as-is because of the UVmapping. TS3/4 outfits are mapped all over arms, hands, necks, etc. of the TS2 skins.

Try this: https://rented-space.tumblr.com/pos...groups-in-simpe (Bloom explained it a bit more here).
And go into Bodyshop and make a new recolor of the file. Bodyshop will automatically add the extra resources you need.
Make sure you then go to the "cMaterialdefinition" tab in the TXMT for the new group and change it from "SimSkin" to "SimStandardMaterial". Otherwise you'll have a lot of strange texture bits all over the skin.

If the files aren't showing properly, have you tried deleting the cache files?
Test Subject
Original Poster
#9 Old 5th Apr 2020 at 10:32 PM
Okay that must be it then, that makes sense. Do I need to go back and delete the skin parts of the converted mesh since I merged my old body group with the outfit, or should I just go back and redo the bones with just the outfit and then import the body basemesh back in? I edited the UVs a little bit already but it was mostly just scaling them to the correct places and I just put the hands and skin into a transparent part of the texture, I'll go back and use one of the UV grid templates and adjust the texture there I suppose. Is there a good way to mark seams in the mesh in milkshape or should I try and go into another program to do that? Sorry for all the questions, I appreciate the help.
Mad Poster
#10 Old 5th Apr 2020 at 10:38 PM
If the skin parts are from a TS2 mesh you can separate them from the mesh and use this as the "body" group. Don't edit the UVs any more than they'd still look good on a TS2 skin.

If the skin parts are from a TS3 or TS4 mesh you'll need to redo them as TS2 skin parts. They really won't look good otherwise. Import over a naked body from whichever age/gender you're making clothes for, then chop off parts you don't need (but leave some overhang into the mesh so it's easier to combine them later). Most of the time this is possible to do in Milkshape.

I think the TS3/TS4 tutorials tend to go over these steps, so you may want to go back and see what the tutorial you used say.
Back to top